Reversing Shared Objects

As we briefly discussed in the section of Android Fundamentals, Android applications sometimes include native C++ code, typically
integrated through the Native Development Kit (NDK). Developers may use native code to improve performance, reduce latency, or add a layer of
complexity that makes reverse engineering more difficult. When the application is compiled, any native code is packaged into shared object (.so) files

within the APK.

These shared objects are susceptible to the same types of security issues we've already been investigating—such as hardcoded credentials,
obfuscation logic, or exploitable flaws—only now they may be buried deeper in compiled native code. Analyzing . so files is therefore an important part
of the broader reverse engineering process and plays a key role in advanced app analysis and malware research, which we'll explore in more detail in

future modules.

While JADX is commonly used to analyze the Java code of an application, tools like , and are preferred for examining shared

objects. In our upcoming example, we'll use Ghidra to analyze the native code.

Reading Strings Directly from SO Files

The following example features a weather forecast app that uses a private APl key to fetch remote data and display it locally. As seen in several previous
labs, uncovering hardcoded or improperly stored API keys is a recurring issue in mobile application security. If a private API key falls into the wrong
hands, it can lead to a variety of damaging outcomes depending on the key’s privileges and intended use. An attacker could gain unauthorized access
to backend systems, incur financial costs by abusing paid services, exfiltrate or manipulate data, disrupt service functionality, or impersonate legitimate

users. The screenshot below shows the application's main screen. The screenshot below shows the application's main screen.

WeatherApp

Weather App

CHECK WEATHER

Tuesday: Partly cloudy
Wednesday: Sunny skies
Thursday: Light showers

Friday: Heavy rain showers

The decompiled code in JADX reveals the following.

/* loaded from: classes.dex */

public class MainActivity extends AppCompatActivity {
Button checkWeatherButton;
EditText cityEditText;
TextView resultTextView;

public native String getAPIKey();
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static {
. loadLibrary("myapp");

}

Reading the Java code of the app, we can understand that the shared library called myapp is used, and the native method getAPIKey() is initialized. A
few lines below, we notice that there is an HTTP request to the URL http://api.weather.org/data/2.5/weather using the value retrieved from the

native method getAPIKey ().

/* JADX INFO: Access modifiers changed from: protected */
v // android.os.AsyncTask
public doInBackground( Joua StrArr) {
str = strArr(0];

try {
HttpURLConnection httpURLConnection = (HttpURLConnection) new URL(
"http://api.weather.org/data/2.5/weather?q=" + str + "&appid=" + MainActivity.this.getAPIKey()).
openConnection();

Let's check if we can retrieve the API key from the shared library. First, we'll extract the files from the APK using either APKTool or unzip.

o0 Reversing Shared Objects

rllk@htb[/htb]$ unzip myapp.apk

This will extract the file 1ib/x86_64/1ibmyapp.so, which, as the name implies, is the name of the library (myapp) with the prefix 1ib. Issuing the strings
command to search the file for the APl key and using grep to filter the output (for the words api, key, or other possible combinations) unfortunately

does not reveal the API key. However, another approach is to use regular expressions to filter the result.

o 0 Reversing Shared Objects

rllk@htb[/htb]$ strings 1ib/x86_64/1libmyapp.so | grep -E "[a-zA-Z0-9_-1{60,}"

xmjPceilOE5ekn6QisfFIXLVSxg3n7HkfK9duVIxaqlLPxZ4eB9EiYacvgswubvKZ
N12_GLOBAL__N_116itanium_demangle24ForwardTemplateReferenceE

N12_GLOBAL__N_116itanium_demangle26SyntheticTemplateParamNameE .
N12_GLOBAL__N_116itanium_demangle24NonTypeTemplateParamDeclE
N12_GLOBAL__N_116itanium_demangle25TemplateTemplateParamDeclE
N12_GLOBAL__N_116itanium_demangle27ExpandedSpecialSubstitutionE

The above command will search for strings in the file that are 60 characters or more. If there are no results, we can try lowering the character length
until we see some output. In this example, we extract the string xmjPceil0E5ekn6QisfF1XLVSxq3n7HkfK9duVIxaqLPxZ4eB9EiYacvgswubvKZ, a potential

API key we could use to examine the application's endpoints further.

Reading Hardcoded Strings With Ghidra

Now, let's assume that the output was too big, or that there was was no way to tell which string was the API key. In such cases, we would need an

alternative way to retrieve it. Fortunately, this can be done with Ghidra. In Debian-based Linux, Ghidra can be installed as follows.

o0 Reversing Shared Objects

rllk@htb[/htb]$ apt install ghidra

Once it's done installing, we can launch it from the command line.

o0 Reversing Shared Objects

rl1k@htb[/htb]$ ghidra

When Ghidra is done launching, click on File -> New Project -> Non-Shared Project -> Next. Then, give a Project Name and click Next again. Once
the project is created, click on File -> Import File, navigate to the 1ibmyapp.so file, click Select File To Import and click 0K to the following pop-up

windows. Next, double-click on the imported file, click Yes and Analyze on the next pop-up window. The following image shows Ghidra's layout after
eSS
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Below is a quick overview of the basic panes we'll be working with in Ghidra while reversing shared libraries.

Checking the functions used in this file under Symbol Tree at the left of the window reveals the function

Java_com_hackthebox_myapp_MainActivity_getAPIKey.

aaa Symbol Tree

> [Ca Imports
> [ Exports
v [ Functions
> O _
> O FUN_001
> § Java_com_hackthebox_myapp_MainActivity_getAPIKey
> |5 operator.
> |5 Labels
> |19 Classes
> [C{yNamespaces

Let's click on it and check the decompiled code in the Decompile window on the right.

local_1¢@
) = IB';

= '9';

local_27._2_

local_27

uStack_1f._|
uStack_1f._
uStack_1f._2_1_
uStack_1f._3_1_
uStack_1b._0_1_=
uStack_1b._1.1_ =
uStack 1b. 2 1




/* try { // try from 00117020 to 001170a5 has
uvarl = (xk(code k) (xparam_1 + 0x538))(param_1,&local_27);
if (*(long *)(in_FS SET + 0x28) != local_10) {

/* WARNING: Subroutine does not return */
__stack_chk_fail();
}

return uVarl;

The above table of characters reveals the string B9EiYacvgswubvKZ. Given the name of the function and the fact that this is its return value, we've found

a candidate for a possible API key.

Reading Code With Ghidra

In the previous example, we saw how to retrieve hardcoded strings from a shared library using Ghidra. In the following example, we will try to read and
understand the code in order to retrieve the API key. Looking at the Symbol Tree pane under the Functions, we can see the functions

Java_com_hackthebox_myapp_MainActivity_getAPIKey and deobfuscate.

aaa Symbol Tree

> [Cla Imports
> [ Exports
v £ Functions
="
§ deobfuscate
> [ FUN_001
¥ Java_com_hackthebox_myapp_MainActivity_getAPIKey
> [C= operator.
> [Cp Labels
> |19 Classes
> |={)} Namespaces

Let's click on the first on the Java_com_hackthebox_myapp_MainActivity_getAPIKey and check the Decompiler pane.

undefined8 Java_com_hackthebox_myapp_MainActivity getAPIKey(long *param_1)

{
undefined8
undefined *
long in_FS_
basic_string Lo
undefined loc
undefined *lo
uint local_
undefined4
undefined4
undefined4
undefined4 xl
long local_10;

= *(long *)(in_FS_OFFSET + 0x28);

(=]
x

N
>

.
'

0xb9998c96;
@xa9%b3a7ce;
@xcc8e87ac;
0x94b7c891;
0xaf959287;
0x93969a9c;
0x9%acabacf;
0xaec99194;
*)(local_18 + 8) = 0;
ry { // try from 0012012a to 00120138 has its CatchHandler @ 001201c7 */
deobfuscate(&lo 40);
puvar2 = local
if (((byte) 40 & 1) = 0) {
puvar2 = 3f;

}

nnnn s

The above snippet is the high-level representation of the assembly code of the shared object. As we can see, various local variables and memory
allocations are set up for the execution. Let's break them down so we can better understand what is happening. The local_18 is dynamically allocated
0x30 (48 bytes) bytes of memory, filled with some hexadecimal values, likely representing the obfuscated API key. The deobfuscate(); function is
called with the address of Local_40 as its argument. Although there is no direct connection between local_18 and deobfuscate(), we could still
assume that the value passed is eventually the hexadecimal values contained in the local_18 variable. A logical explanation for why this is not clear
could be that due to an oversight in the reverse-engineering process, there might have been a function that populates local_40 using the data from

local_18 before the deobfuscate () function is called, which is not shown. Let's double-click on the deobfuscate() to further examine its functionality.

basic_string * deobfuscate(basic_string *param_1)

{




*(undefined (%) [16])param_1 = ZEXT816(0);
*(undefined8 *)(param_1 + 0x10) = 0;
if ((*in_RSI & 1) == 0) {

= (ulong) (*in_RSI >> 1);

2 = x*(ulong *)(in_RSI + 8);
= x(byte *k) (in_RSI + 0x10);

2 '=0) {

/* try { // try from 00120097 to 0012009e has its CatchHandler @ 001200b7 */
std::__ndkl::basic_string<char,std::__ndkl::char_traits<char>,std::_ ndkl::allocator<char>>::
push_back((basic_string<char,std::__ndkl::char_traits<char>,std::__ndkl::allocator<char>> x)

param_1,~pbVar3[uvarl]);
uvarl = uVarl + 1;
} while (uva I= uvarl);
}

return param_1;

Inside the deobfuscate () function, we can see that the memory structure of the variable in_RSI is checked. We can assume that this is the obfuscated
API key since, in many calling conventions, the RSI register is used to pass the function's second argument. If its least significant bit is O, the string is
short and stored inline. Otherwise, the string is long and stored in dynamically allocated memory. The function then goes through each string character
and appends its bitwise negation to param_1. In simpler terms, it's flipping the bits for each character. This is a really simple obfuscation method that

should not be used in production. The value param_1 is then returned to the Java_com_hackthebox_myapp_MainActivity_getAPIKey() function

Now that we know the code's functionality in the shared library, we can try to retrieve the initial API key. To shape the obfuscated string, we will need to
take the hexadecimal values stored in the variable Local_18 and arrange them in the correct order. Before starting, however, we need to keep in mind
that the x86-64 system architecture uses the little-endian format. This means, for example, that the value 0xaf959287 will become 0x879295af. Reading

the content of the Java_com_hackthebox_myapp_MainActivity_getAPIKey() function reveals the following hexadecimal values.

10 = *(long *)(in_FS_OFFSET + 0x28);
(undefined4 *)operator.new(0x30);
0x31;

0x20;
0;
0xb9998c96;

0xa9b3a7ce;

@xccB8e87ac;

0x94b7c891; N
xaf959287;

0x93969a9c;
@x9acabacf;
0xaec99194;

s nn

Let's take the above values and place them in sequental order. Since the arrays start from 8 and not 1, our frst value will be *local_18 = 0xaf959287,
followed by local_18[1] = 0x93969a9c, etc. We will also apply big-endian formatting to reverse the existing little-endian formatting. Finally, we will

remove the x0 prefix to produce the following hex sequence.

L BN Reversing Shared Objects

879295af 9c9a9693 cfbaca9a 9491c%ae 968c99b9 cea7b3a9 ac878ecc 91c8b794

Now, we can use the online —or any other calculator with bitwise NOT operation—to get the initial string value of the API key. Before pasting

the above sequence to the calculator, make sure it's in the following format.

_ BN Reversing Shared Objects

87 92 95 af 9¢c 9a 96 93 cf ba ca 9a 94 91 c9 ae 96 8c 99 b9 ce a7 b3 a9 ac 87 8e cc 91 c8 b7 94

Input: Paste binary numbers below (1 per line)
1 87 92 95 af 9c 9a 96 93 cf ba ca 9a 94 91 c9 ae 96 8c 99 b9 ce a7 b3 a9 ac 87 8e cc 91 c8 b7 94

Size: 95
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Then, press the blue Calculate button and check the Ascii Result section.

Ascii Result:

A T NS wo X < X P T un oo X0 UMme ~ R 0O TV 3 X

he result of NOT operation in Ascii

As we can see, the API key xmjPceil0E5ekn6QisfF1XLVSxg3n7Hk is now visible. Fortunately for us, it only took a few steps to retrieve it successfully.
However, other more complicated obfuscation methods can be used to make the process of reading the source code even more difficult. We wiill

showcase examples of these in later in the module.
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Answer the question(s) below to complete this Section and earn cubes!

+38 Analyze the APK file found inside the attached "myapp_shared_libs_1.zip" archive. What is the API key value?

Submit your answer here...
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+58 Analyze the APK file found inside the attached "myapp_shared_libs_2.zip" archive. What is the API key value?
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