IPv4 Routing with OSPF

Task - OSPF Router Identifiers

Solutions:

R1:

router ospf 1
 router-id 1.1.1.1
 network 172.16.12.1 0.0.0.0 area 0
 network 172.16.13.1 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R2:

router ospf 1
 router-id 2.2.2.2
 network 172.16.12.2 0.0.0.0 area 0
 network 172.16.23.2 0.0.0.0 area 0
 network 172.16.24.2 0.0.0.0 area 0
 network 172.16.25.2 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R3:

router ospf 1
 router-id 3.3.3.3
 network 172.16.13.3 0.0.0.0 area 0
 network 172.16.23.3 0.0.0.0 area 0
 network 172.16.34.3 0.0.0.0 area 0
 network 172.16.36.3 0.0.0.0 area 0
 network 172.16.103.3 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R4:

router ospf 1
 router-id 4.4.4.4
 network 172.16.24.4 0.0.0.0 area 0
 network 172.16.34.4 0.0.0.0 area 0
 network 172.16.45.4 0.0.0.0 area 0
 network 172.16.46.4 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R5:

router ospf 1
 router-id 5.5.5.5
 network 172.16.25.5 0.0.0.0 area 0
 network 172.16.45.5 0.0.0.0 area 0
 network 172.16.56.5 0.0.0.0 area 0
 network 172.16.57.5 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R6:

router ospf 1
 router-id 6.6.6.6
 network 172.16.36.6 0.0.0.0 area 0
 network 172.16.46.6 0.0.0.0 area 0
 network 172.16.56.6 0.0.0.0 area 0
 network 172.16.68.6 0.0.0.0 area 0
 network 172.16.106.6 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R7:

router ospf 1
 router-id 7.7.7.7
 network 172.16.57.7 0.0.0.0 area 0
 network 172.16.78.7 0.0.0.0 area 0
 network 172.16.79.7 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R8:

router ospf 1
 router-id 8.8.8.8
 network 172.16.68.8 0.0.0.0 area 0
 network 172.16.78.8 0.0.0.0 area 0
 network 172.16.89.8 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R9:

router ospf 1
 router-id 9.9.9.9
 network 172.16.79.9 0.0.0.0 area 0
 network 172.16.89.9 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

R10:

router ospf 1
 router-id 10.10.10.10
 network 172.16.103.10 0.0.0.0 area 0
 network 172.16.106.10 0.0.0.0 area 0

interface Loopback0
 ip ospf 1 area 0

Verification:

R1#sh ip ospf  neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:38    172.16.13.3     GigabitEthernet0/1
2.2.2.2           1   FULL/DR         00:00:38    172.16.12.2     GigabitEthernet0/0

R1#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 29 subnets, 2 masks
O        172.16.2.2/32 [110/2] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.3.3/32 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.4.4/32 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                       [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.5.5/32 [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.6.6/32 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.7.7/32 [110/4] via 172.16.12.2, 00:01:48, GigabitEthernet0/0
O        172.16.8.8/32 [110/4] via 172.16.13.3, 00:01:38, GigabitEthernet0/1
O        172.16.9.9/32 [110/5] via 172.16.13.3, 00:01:28, GigabitEthernet0/1
                       [110/5] via 172.16.12.2, 00:01:28, GigabitEthernet0/0
O        172.16.10.10/32 [110/3] via 172.16.13.3, 00:01:58, GigabitEthernet0/1
O        172.16.23.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.24.0/24 [110/2] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.25.0/24 [110/2] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.34.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.36.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.45.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                        [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.46.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                        [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.56.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                        [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.57.0/24 [110/3] via 172.16.12.2, 00:01:48, GigabitEthernet0/0
O        172.16.68.0/24 [110/3] via 172.16.13.3, 00:01:38, GigabitEthernet0/1
O        172.16.78.0/24 [110/4] via 172.16.13.3, 00:01:38, GigabitEthernet0/1
                        [110/4] via 172.16.12.2, 00:01:38, GigabitEthernet0/0
O        172.16.79.0/24 [110/4] via 172.16.12.2, 00:01:28, GigabitEthernet0/0
O        172.16.89.0/24 [110/4] via 172.16.13.3, 00:01:28, GigabitEthernet0/1
O        172.16.103.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.106.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1

R1# sh ip ospf 
 Routing Process "ospf 1" with ID 1.1.1.1
 Start time: 06:47:21.880, Time elapsed: 00:05:13.817
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Supports NSSA (compatible with RFC 3101)
 Supports Database Exchange Summary List Optimization (RFC 5243)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
  router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 3 (1 loopback)
 Area has no authentication
 SPF algorithm last executed 00:02:58.328 ago
 SPF algorithm executed 9 times
 Area ranges are
 Number of LSA 19. Checksum Sum 0x08C946
 Number of opaque link LSA 0. Checksum Sum 0x000000
 Number of DCbitless LSA 0
 Number of indication LSA 0
 Number of DoNotAge LSA 0
 Flood list length 0

R10#sh ip ospf 
 Routing Process "ospf 1" with ID 10.10.10.10
 Start time: 06:49:01.543, Time elapsed: 00:05:21.795
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Supports NSSA (compatible with RFC 3101)
 Supports Database Exchange Summary List Optimization (RFC 5243)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
  router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 3 (1 loopback)
 Area has no authentication
 SPF algorithm last executed 00:04:46.209 ago
 SPF algorithm executed 4 times
 Area ranges are
 Number of LSA 19. Checksum Sum 0x08C946
 Number of opaque link LSA 0. Checksum Sum 0x000000
 Number of DCbitless LSA 0
 Number of indication LSA 0
 Number of DoNotAge LSA 0
 Flood list length 0