IPv4 Routing with OSPF

Task - Implementing OSPF Authentication

Solutions:

R1-R10:

router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

R3:

interface GigabitEthernet0/0
 ip ospf authentication
 ip ospf authentication-key cisco

router ospf 1
 area 0 authentication message-digest

interface GigabitEthernet0/1
 ip ospf message-digest-key 1 md5 cisco

interface GigabitEthernet0/7
 ip ospf message-digest-key 1 md5 cisco

interface GigabitEthernet0/5
 ip ospf authentication null 

interface GigabitEthernet0/6
 ip ospf authentication null

R6:

interface GigabitEthernet0/1
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco

R10:

interface GigabitEthernet0/0
 ip ospf authentication
 ip ospf authentication-key cisco

interface GigabitEthernet0/1
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco

R2:

router ospf 1
 area 0 authentication message-digest

interface GigabitEthernet0/0
 ip ospf message-digest-key 1 md5 cisco

interface GigabitEthernet0/7
 ip ospf message-digest-key 1 md5 cisco

interface GigabitEthernet0/5
 ip ospf authentication null 

interface GigabitEthernet0/6
 ip ospf authentication null


R1:

router ospf 1
 area 0 authentication message-digest

interface GigabitEthernet0/0
 ip ospf message-digest-key 1 md5 cisco

interface GigabitEthernet0/1
 ip ospf message-digest-key 1 md5 cisco

Verification:

R1#sh ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.3.3        1   FULL/DR         00:00:38    172.16.13.3     GigabitEthernet0/1
172.16.2.2        1   FULL/DR         00:00:38    172.16.12.2     GigabitEthernet0/0


R1#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 29 subnets, 2 masks
O        172.16.2.2/32 [110/2] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.3.3/32 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.4.4/32 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                       [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.5.5/32 [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.6.6/32 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.7.7/32 [110/4] via 172.16.12.2, 00:01:48, GigabitEthernet0/0
O        172.16.8.8/32 [110/4] via 172.16.13.3, 00:01:38, GigabitEthernet0/1
O        172.16.9.9/32 [110/5] via 172.16.13.3, 00:01:28, GigabitEthernet0/1
                       [110/5] via 172.16.12.2, 00:01:28, GigabitEthernet0/0
O        172.16.10.10/32 [110/3] via 172.16.13.3, 00:01:58, GigabitEthernet0/1
O        172.16.23.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.24.0/24 [110/2] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.25.0/24 [110/2] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.34.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.36.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.45.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                        [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.46.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                        [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.56.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
                        [110/3] via 172.16.12.2, 00:02:46, GigabitEthernet0/0
O        172.16.57.0/24 [110/3] via 172.16.12.2, 00:01:48, GigabitEthernet0/0
O        172.16.68.0/24 [110/3] via 172.16.13.3, 00:01:38, GigabitEthernet0/1
O        172.16.78.0/24 [110/4] via 172.16.13.3, 00:01:38, GigabitEthernet0/1
                        [110/4] via 172.16.12.2, 00:01:38, GigabitEthernet0/0
O        172.16.79.0/24 [110/4] via 172.16.12.2, 00:01:28, GigabitEthernet0/0
O        172.16.89.0/24 [110/4] via 172.16.13.3, 00:01:28, GigabitEthernet0/1
O        172.16.103.0/24 [110/2] via 172.16.13.3, 00:02:36, GigabitEthernet0/1
O        172.16.106.0/24 [110/3] via 172.16.13.3, 00:02:36, GigabitEthernet0/1

R3#sh ip ospf  interface g0/0
GigabitEthernet0/0 is up, line protocol is up 
  Internet Address 172.16.103.3/24, Area 0, Attached via network Statement
  Process ID 1,  router ID 172.16.3.3, network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State WAITING, Priority 1
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
    Wait time before Designated router selection 00:00:31
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
 neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

R3#sh ip ospf  interface g0/1
GigabitEthernet0/1 is up, line protocol is up 
  Internet Address 172.16.13.3/24, Area 0, Attached via network Statement
  Process ID 1,  router ID 172.16.3.3, network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated  router (ID) 172.16.3.3, Interface address 172.16.13.3
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
 neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)
  Cryptographic authentication enabled
    Youngest key id is 1